Metasploit For Mac Os X

Well, I started to use metasploit and I tried to search some exploits for Mac OS X Yosemite, but there were nothing. Is the OS too safe to get hacked with metasploit or what's the problem? I really want to solve this problem, cause my victims Computer is running on OSX.

Install Metasploit on OS X
# XCode Command Line Tools
>xcode-select --install
# Install Homebrew
>ruby -e '$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)'
>echo PATH=/usr/local/bin:/usr/local/sbin:$PATH >> ~/.bash_profile
>source ~/.bash_profile
>brew tap homebrew/versions
# Install nmap
>brew install nmap
# Install libxml2
>brew install libxml2
# Install PostgreSQL
>brew install postgresql --without-ossp-uuid
# ruby 2.1.X
>brew install homebrew/versions/ruby21
# Initialize the database
>initdb /usr/local/var/postgres
>mkdir -p ~/Library/LaunchAgents
>cp /usr/local/Cellar/postgresql/9.4.0/homebrew.mxcl.postgresql.plist ~/Library/LaunchAgents/
>launchctl load -w ~/Library/LaunchAgents/homebrew.mxcl.postgresql.plist
>echo 'alias pg_start='pg_ctl -D /usr/local/var/postgres -l /usr/local/var/postgres/server.log start'
>echo 'alias pg_stop='pg_ctl -D /usr/local/var/postgres stop'
# Create the db for the metasploit framework
>createuser msf -P -h localhost
>createdb -O msf msf -h localhost
# Clone the Git Metasploit
>git clone https://github.com/rapid7/metasploit-framework.git /usr/local/share/metasploit-framework
# settings Env
>echo 'alias msfconsole='/usr/local/share/metasploit-framework && ./msfconsole && cd -' >> ~/.zshrc
>echo 'alias msfbinscan='/usr/local/share/metasploit-framework && ./msfbinscan && cd -' >> ~/.zshrc
>echo 'alias msfd='/usr/local/share/metasploit-framework && ./msfd && cd -' >> ~/.zshrc
>echo 'alias msfelfscan='/usr/local/share/metasploit-framework && ./msfelfscan && cd -' >> ~/.zshrc
>echo 'alias msfmachscan='/usr/local/share/metasploit-framework && ./msfmachscan && cd -' >> ~/.zshrc
>echo 'alias msfpescan='/usr/local/share/metasploit-framework && ./msfpescan && cd -' >> ~/.zshrc
>echo 'alias msfrop='/usr/local/share/metasploit-framework && ./msfrop && cd -' >> ~/.zshrc
>echo 'alias msfrpc='/usr/local/share/metasploit-framework && ./msfrpc && cd -' >> ~/.zshrc
>echo 'alias msfrpcd='/usr/local/share/metasploit-framework && ./msfrpcd && cd -' >> ~/.zshrc
>echo 'alias msfupdate='/usr/local/share/metasploit-framework && ./msfupdate && cd -' >> ~/.zshrc
>echo 'alias msfvenom='/usr/local/share/metasploit-framework && ./msfvenom && cd -' >> ~/.zshrc
>sudo chmod go+w /etc/profile
>sudo echo export MSF_DATABASE_CONFIG=/usr/local/share/metasploit-framework/config/database.yml >> /etc/profile
>cd /usr/local/share/metasploit-framework
>bundle install
# Create the Database Configuration
>vim /usr/local/share/metasploit-framework/config/database.yml
Paste the following text:
production:
adapter: postgresql
database: msf
username: msf
password: <your password>
host: 127.0.0.1
port: 5432
pool: 75
timeout: 5
# update your environment
>source /etc/profile
>source ~/.bash_profile
> msfconsole
Metasploit For Mac Os X

Install Metasploit On Mac

Mac

Uninstall Metasploit Mac Os X

Sign up for freeto join this conversation on GitHub. Already have an account? Sign in to comment

Install Metasploit On Windows 10

  • Metasploit su Mac Os X Mac OS X 10.5 (Leopard) and 10.6 (Snow Leopard) come pre-installed with Ruby 1.8, but we recommend that you install Ruby 1.9 from MacPorts instead. Install MacPorts.
  • 1) Before we start installing Metasploit Framework, we need to make sure the system has already installed Appleā€™s Development Tool XCode. At the time when I am writing this article, the Mac OS X version I am using with is Mac OS X Lion (version 10.7.4), and XCode 4.5.2.